Minecraft Server List Icon

Concordia MC Minecraft Server

This is the information page for the Concordia MC server. Here you can find answers to all of the questions you may have about Concordia MC to make sure it would be a good fit for you!

Concordia MC

0 / 0 players online

Server Banner

Key things about Concordia MC:
- We are a Semi-vanilla SMP server on Java 1.20.2!!
- Economy and shopping district included! (you can own your own shop as well 😉)
- Help channels are readily available in our discord.
- Donator roles can be purchased *OR earned through referring friends!
- English language only. This is to ensure our rules can be upheld within chat.
- Hosted in Eastern North America! No lag can be felt from Western NA, Eastern NA and Europe!
- No PVP (unless both players consent) - it's a chill place to hang with friends without any drama!
- A very good Anti-Cheat plugin keeps those pesky hackers away.
- Land claimingis incorporated via the Residence plugin!
- Future plans include a housing district at spawn, regular fun events, minigames, competitions and fun events.

Vote for Concordia MC

Vote every 24 hours to get rewards and support Concordia MC!

Player Stats

5 / 5.0

Reviews

0 reviews total

  • No reviews have been written for this server yet!

Frequently Asked Questions

  • How do I join Concordia MC?

    Joining servers is different for both Java and Bedrock platforms. If you are a Java player, simply select 'Add Server' or 'Direct Connection', and enter the IP address: concordiamc.apexmc.co:25564. If you are a Bedrock player (this server must support Bedrock in order to join on Bedrock) use the address along with the port: 19132.

  • Which Gamemodes does Concordia MC have?

    Every Minecraft server has it's own gamemode. Concordia MC features Survival, PvE, Vanilla, and Economy. If you enjoy any of these gamemodes, Concordia MC might be the server for you!'

  • Which Versions does Concordia MC support?

    Minecraft has many different versions - each with their own features. Concordia MC supports 1.20 connectivity, so make sure you join on one of those versions!